EPS light came on!!!! - Yamaha Grizzly ATV Forum
Grizzly Electrical & Lighting Discuss Grizzly electrical and lighting modifications here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 01-03-2010, 10:35 AM Thread Starter
 
Join Date: Mar 2009
Location: Ontario Canada
Age: 31
Posts: 102
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 98
 
EPS light came on!!!!

Hey guys. I was out riding my bike through some snow drifts on my lake yesterday in the bitter cold. I mean like 30 below cold. I just happend to look down and notice that my EPS light had come on. I have never seen this happen before and it was only on for maybe 30 seconds. Im not sure if it was psychological or if my power steering wasnt actually working. It came on again later that day and tis time stayed on for 2 minutes or so. Could this just simply be some snow and ice messing with my electrical or is my EPS unit shot. Let me know what you guys think.!
hardrider is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 01-03-2010, 10:57 AM
 
Grizzrider08's Avatar
 
Join Date: Mar 2008
Location: Vernon, NJ
Age: 26
Posts: 2,744
Thanks: 179
Thanked 447 Times in 367 Posts
Rep Power: 116
                     
I believe theres a circuit breaker in the system, if the EPS gets hot it will shut off, but im not sure if the light would come on. I would look over the connections and make sure everything is tight, better yet disconnect each one and put some dielectric grease in the connections.

08' Grizzly 700 EPS: US Yamaha front brushguard, Full ricochet skids, 3.5" Rox risers, solex bars, odi grips, rox handguards, 27" Maxxis zillas, Tamarack Classic box, Viper 3k winch, 2r tip, 2r foot pegs and traction rails, 2r front receiver, uni filter, pod mod, hanger mod, greasless, Rigid D2s, Rigid 10" SR


2013 Can Am Renegade 1000 XXC

Lots o' mods

Hauler - 2008 Silverado 3500 dually CCLB LTZ
Grizzrider08 is offline  
post #3 of 18 Old 01-03-2010, 11:43 AM
 
grizlock's Avatar
 
Join Date: Jan 2008
Location: Barrie, Ontario Canada
Age: 50
Posts: 223
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 113
 
water

One thing to consider, if there is water in the unit.If in the summer months you have been in deep water,it is possible the seal has been compromised and water has got in.At 30 below it will surly freeze up,causing the unit to fail.I have heard if some fellas getting water in there EPS unit.

08 Blue Grizzly 700.
Warn xt 3000 with remote on front..UNI Filter.2R Tip.
Plano rear storage box.
ITP SS 106 RIMS 26" Maxxis Zillas.
Moose front bumper.Ricochet full skids.
Rear 2500 winch,custom made mount.
Garmen Legend
, RAM mount.
grizlock is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old 01-03-2010, 11:46 AM
 
Trailhunter's Avatar
 
Join Date: Dec 2006
Age: 36
Posts: 644
Thanks: 20
Thanked 80 Times in 58 Posts
Rep Power: 125
             
I was going to start a thread on this yesterday as well. I was working on my clutch ...........i had the belt cover off and i ran the bike for about 3 mins to check for clearence issues. I turned the bike off put the belt cover back on. Started it up to put it in the back of my truck and my steering felt heivy ....looked down an dthe light was on. Then when i drove in the truck it turned off. Friggin wierd

2007 grizzly 700
my hair straight back vid
http://www.youtube.com/watch?v=HikVJsvd7JY

my on going grizzly custom parts project

http://www.grizzlycentral.com/forum/...home-brew.html
Trailhunter is offline  
post #5 of 18 Old 01-03-2010, 11:48 AM
 
Join Date: Jul 2009
Age: 44
Posts: 2,322
Thanks: 58
Thanked 378 Times in 335 Posts
Rep Power: 99
                     
never had the light come on when eps got hot but I could feel the steering get heavier
jake72 is online now  
post #6 of 18 Old 01-03-2010, 11:50 AM
 
Join Date: Jul 2009
Age: 44
Posts: 2,322
Thanks: 58
Thanked 378 Times in 335 Posts
Rep Power: 99
                     
Quote:
Originally Posted by hardrider View Post
Hey guys. I was out riding my bike through some snow drifts on my lake yesterday in the bitter cold. I mean like 30 below cold. I just happend to look down and notice that my EPS light had come on. I have never seen this happen before and it was only on for maybe 30 seconds. Im not sure if it was psychological or if my power steering wasnt actually working. It came on again later that day and tis time stayed on for 2 minutes or so. Could this just simply be some snow and ice messing with my electrical or is my EPS unit shot. Let me know what you guys think.!
did you have a lot of snow up around all the connections and the eps motor
jake72 is online now  
post #7 of 18 Old 01-03-2010, 01:01 PM
 
blum's Avatar
 
Join Date: Apr 2009
Age: 58
Posts: 107
Thanks: 3
Thanked 21 Times in 16 Posts
Rep Power: 97
     
I have had my light come on a couple of times and both times I was sitting still turning the tires on concrete. The steering went dead and all I did was start driving and turn the handle bars side to side and the light would go off. I have never had one come on in the snow yet. I just figured that the ECM was telling me I need to ride more.
blum is offline  
post #8 of 18 Old 01-03-2010, 03:23 PM Thread Starter
 
Join Date: Mar 2009
Location: Ontario Canada
Age: 31
Posts: 102
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 98
 
Well thanks for all the input guys. Im crossing my fingers and hoping that it is just snow built up. Its so cold here right now even if i tried to melt the snow the water would instantly freeze lol. Is there any damage that can come from running it as it is or is it doing what its designed to do by turning off and on?
hardrider is offline  
post #9 of 18 Old 01-03-2010, 03:42 PM
 
Join Date: Jul 2009
Age: 44
Posts: 2,322
Thanks: 58
Thanked 378 Times in 335 Posts
Rep Power: 99
                     
Quote:
Originally Posted by hardrider View Post
Well thanks for all the input guys. Im crossing my fingers and hoping that it is just snow built up. Its so cold here right now even if i tried to melt the snow the water would instantly freeze lol. Is there any damage that can come from running it as it is or is it doing what its designed to do by turning off and on?
as long as there is no water inside seal unit where the plastic gear is your alright
jake72 is online now  
post #10 of 18 Old 01-03-2010, 04:45 PM Thread Starter
 
Join Date: Mar 2009
Location: Ontario Canada
Age: 31
Posts: 102
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 98
 
Well i just took her back out to the ice hut and its still blowing like bugger and cold as hell. No EPS light on that run so ill keep my fingers crossed. Thanks again guys.
hardrider is offline  
post #11 of 18 Old 01-03-2010, 07:39 PM
 
Bill Nobles's Avatar
 
Join Date: Nov 2009
Location: Mangham, Louisiana
Age: 37
Posts: 478
Thanks: 96
Thanked 20 Times in 20 Posts
Rep Power: 90
     
ITS GONNA LOCK UP!!!!!!
Bill Nobles is offline  
post #12 of 18 Old 01-03-2010, 08:11 PM Thread Starter
 
Join Date: Mar 2009
Location: Ontario Canada
Age: 31
Posts: 102
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 98
 
Really???? Care to elaborate please LOL. What can i do to avoid that.?
hardrider is offline  
post #13 of 18 Old 01-03-2010, 09:31 PM
 
Join Date: Jul 2009
Age: 44
Posts: 2,322
Thanks: 58
Thanked 378 Times in 335 Posts
Rep Power: 99
                     
Quote:
Originally Posted by hardrider View Post
Really???? Care to elaborate please LOL. What can i do to avoid that.?
change it over to manual lol
jake72 is online now  
post #14 of 18 Old 01-03-2010, 09:58 PM
 
ganny76's Avatar
 
Join Date: Oct 2009
Location: Chattahoochee, Florida
Posts: 142
Thanks: 4
Thanked 13 Times in 12 Posts
Rep Power: 91
   
Probably a stupid question, but I guess the EPS doesn't work when you are not moving? When I am in a hole trying to manuever a way out and you are stopped trying to cut the wheels, I have to bear down on it just like mine without EPS. Do you have to be moving for it to work?

'07 Camo Grizzly 700 EFI EPS, Yamamods Tip, 450 Clutch Weights, 29.5 Outlaws, Shifter and break covers from "Custom Covers"

09 Rhino 450, 30' Zillas w/ 14' SS 212's, 3" Extreme Lift, Viper Elite 4500 Winch
ganny76 is offline  
post #15 of 18 Old 01-03-2010, 11:14 PM
 
Grizzrider08's Avatar
 
Join Date: Mar 2008
Location: Vernon, NJ
Age: 26
Posts: 2,744
Thanks: 179
Thanked 447 Times in 367 Posts
Rep Power: 116
                     
Quote:
Originally Posted by ganny76 View Post
Probably a stupid question, but I guess the EPS doesn't work when you are not moving? When I am in a hole trying to manuever a way out and you are stopped trying to cut the wheels, I have to bear down on it just like mine without EPS. Do you have to be moving for it to work?
Yep, the EPS only works when your moving. Personally i think it should be going at all times, with alot of assist when sitting still.

08' Grizzly 700 EPS: US Yamaha front brushguard, Full ricochet skids, 3.5" Rox risers, solex bars, odi grips, rox handguards, 27" Maxxis zillas, Tamarack Classic box, Viper 3k winch, 2r tip, 2r foot pegs and traction rails, 2r front receiver, uni filter, pod mod, hanger mod, greasless, Rigid D2s, Rigid 10" SR


2013 Can Am Renegade 1000 XXC

Lots o' mods

Hauler - 2008 Silverado 3500 dually CCLB LTZ
Grizzrider08 is offline  
Reply

  Lower Navigation
Go Back   Yamaha Grizzly ATV Forum > Grizzly Forums > Grizzly Electrical & Lighting


Search tags for this page
07 700 grizzly eps light on
,
2007 yamaha grizzly 700 eps light on
,
2008 grizzly 700 eps light is on
,
eps light intermittent yamaha grizzly
,
eps light on 2007 yamaha grizzly
,
eps light on yamaha grizzly
,

grizzly 700 eps light on

,
grizzly eps light
,
grizzly eps light code
,
my yamaha grizzly 700 eps light on dashboard when i rev it up
,
why does eps light show up on grizzly 700
,
yamaha grizzly 700 does not start eps ligth is on
,
yamaha grizzly 700 eps light on
,

yamaha grizzly eps light

,
yamaha grizzly eps light stays on
Click on a term to search our sites for related topics.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Helmet Light “HL-001Stator Powered Light” R.MARTIN Grizzly Electrical & Lighting 1 11-26-2009 05:39 PM
temp light and engine light staying on and code 21 ride n dirty Grizzly Electrical & Lighting 10 09-24-2009 02:48 PM
gas light polargrizz General Discussion 1 02-14-2009 04:13 PM
LED Light Bar bdgrizz07 Grizzly Electrical & Lighting 4 11-25-2008 07:16 PM
eps light is on smokeum99ta Grizzly Chassis & Body 13 12-10-2007 08:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome