Diagnostic mode - Yamaha Grizzly ATV Forum
Grizzly Engine & Transmission Discuss your Grizzly engine and transmission modifications here.

 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 07-07-2016, 07:14 PM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
Diagnostic mode

I can't for the life of me get my grizzly into diagnostic mode.


I'm doing it exactly like the manual says. anyone ever experience this?

The only thing i can think of is I unplugged the wrong connection

"Disconnect the wire harness coupler from the fuel pump."

There is only one electrical connection on the fuel pump so I can't figure this out.

basically when I press and hold the buttons the screen goes completely blank and just stays there until I release the buttons then the dash just comes back to life only with teh fuel guage flashing?


what could I be doing wrong
believev is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 07-07-2016, 08:58 PM
 
whiskeymike's Avatar
 
Join Date: Oct 2015
Age: 33
Posts: 1,221
Thanks: 727
Thanked 719 Times in 445 Posts
Rep Power: 54
                     
What grizzly do you have

YACC #44

'13 camo 550-SOLD

'15 700 SE-

-27"bearclaw HTR's/STI beadlocks
-2" snorkels/EHS fuel cont./extended. batt. cables/exh. tip OR barkers
-rox setup
-Switch panel/voltmeter/temp gauge/20"light bar/eagle eye rear lights/led TL panel w/ flash module
-2x pelican 1200/2x pelican 1400 cases
-viper max 3500#/1/4" amsteel blue rope
-ODI rogue
-DIY 1/4" skids/bumper repl.
-machined sheave 3.13:1 ratio, cut camplate
-blocked A.I.S.
whiskeymike is offline  
post #3 of 12 Old 07-08-2016, 05:30 AM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
Quote:
Originally Posted by whiskeymike View Post
What grizzly do you have
09 550 EFI
believev is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 07-08-2016, 07:39 AM
 
reogem's Avatar
 
Join Date: Aug 2011
Location: Northern WI.
Posts: 6,952
Thanks: 2,842
Thanked 3,055 Times in 2,105 Posts
Rep Power: 134
                     
Carefully reread the instructions.
Did you have both the key switch off and the kill switch off?
Did you continue to hold the reset and select buttons for 8 seconds or more after turning on the key switch?
There is only one connector at the fuel pump to disconnect. Some tests require reconnecting the fuel pump.

Some test also require turning the kill switch on.

Twin sister 16 Kodiak EPS 700 Dirty Egg Salad (Camo)
Grezzzless CVT 22g
26.5" Pitbull Growlers Uber XOR
STI HD1 Beadlock Wheels


Hers 16 Kodiak EPS 700 Camo
26.5" Pitbull Growlers Uber XOR
STI HD1 Wheels


2013 Ole blue 700
Putting out to Stud 21365 miles
360/120 CVT
26" ML XTRs
stocker wheels
grezzzless clutch.

Last edited by reogem; 07-08-2016 at 07:44 AM.
reogem is offline  
The Following User Says Thank You to reogem For This Useful Post:
believev (07-08-2016)
post #5 of 12 Old 07-08-2016, 07:59 AM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
Yes - this is where, i'm stuck - there has to be something else. like turn a switch on or something.

My dash does not turn back on - while the select and reset buttons are being held. I waited upwards of a minute, and it just stays blank, until I let go of the buttons then the dash comes back on.



I did: KEY OFF, KILL SWITCH OFF, DISCONNECT GREY PLUG AT FUEL PUMP, PRESS S&R buttons together simultanenous. HELD them down, KEY ON - continued holding forever, and no DIAG mode.

any suggestions? I will try anything at this point.
believev is offline  
post #6 of 12 Old 07-08-2016, 08:01 AM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
does it have to be throwing a code to get into diagnostics mode?
believev is offline  
post #7 of 12 Old 07-08-2016, 08:02 AM
 
Join Date: Nov 2015
Age: 64
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
 
Misery likes company, I have a 2010 550 and my diagnostic won't come up either.
Terrastar is offline  
post #8 of 12 Old 07-08-2016, 08:18 AM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
terrastar - there has to be something in common here.

its possible my dash was replaced on mine - since the miles are pretty low on the dash - I'm wondering if maybe your dash was replaced as well?

maybe the newer dash's are different than what i'm seeing in the manual for mine.


I'd like to get someone who knows alot about these to give me a few things to try - hopefully we can get to the bottom of it. The test procedure out of a 09 550 FI manual does NOT work. so it has to be something simple.
believev is offline  
post #9 of 12 Old 07-08-2016, 08:23 AM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
reogem - can you give me a few combinations of things to try if you are aware of them? The parts diagram says ONLY 550 and 700 FI dash's will work - but I'm suspicius of that. is the 700 procedure different?

2009 GRIZZLY 550 FI 4WD - YFM5FGYB METER
2009 GRIZZLY 550 FI 4WD - YFM5FGYGR METER
2009 GRIZZLY 550 FI 4WD - YFM5FGYL METER
2009 GRIZZLY 550 FI 4WD HUNTER - YFM5FGHY METER
2009 GRIZZLY 700 FI 4WD - YFM7FGYB METER
2009 GRIZZLY 700 FI 4WD - YFM7FGYGR METER
2009 GRIZZLY 700 FI 4WD - YFM7FGYL METER
2009 GRIZZLY 700 FI 4WD HUNTER - YFM7FGHY METER


The ECU box is compatible from 09 to 11 for 550's only. anything ring a bell here?



2009 GRIZZLY 550 FI 4WD - YFM5FGYB ELECTRICAL 1
2009 GRIZZLY 550 FI 4WD - YFM5FGYGR ELECTRICAL 1
2009 GRIZZLY 550 FI 4WD - YFM5FGYL ELECTRICAL 1
2009 GRIZZLY 550 FI 4WD HUNTER - YFM5FGHY ELECTRICAL 1
2009 GRIZZLY 550 FI EPS 4WD - YFM5FGPYB ELECTRICAL 1
2009 GRIZZLY 550 FI EPS 4WD - YFM5FGPYGR ELECTRICAL 1
2009 GRIZZLY 550 FI EPS 4WD - YFM5FGPYL ELECTRICAL 1
2009 GRIZZLY 550 FI EPS 4WD HUNTER - YFM5FGPHY ELECTRICAL 1
2009 GRIZZLY 550 FI EPS 4WD SPECIAL EDITION - YFM5FGPSEY ELECTRICAL 1
2010 550 FI EPS 4WD HUNTER - YFM5FGPHZ ELECTRICAL 1
2010 GRIZZLY 550 FI 4WD - YFM5FGZGR ELECTRICAL 1
2010 GRIZZLY 550 FI 4WD - YFM5FGZL ELECTRICAL 1
2010 GRIZZLY 550 FI 4WD HUNTER - YFM5FGHZ ELECTRICAL 1
2010 GRIZZLY 550 FI EPS 4WD - YFM5FGPZGR ELECTRICAL 1
2010 GRIZZLY 550 FI EPS 4WD - YFM5FGPZL ELECTRICAL 1
2011 GRIZZLY 550 4WD - YFM5FGAGR ELECTRICAL 1
2011 GRIZZLY 550 4WD HUNTER - YFM5FGHA ELECTRICAL 1
2011 GRIZZLY 550 EPS 4WD - YFM5FGPAGR ELECTRICAL 1
2011 GRIZZLY 550 EPS 4WD - YFM5FGPAL ELECTRICAL 1
2011 GRIZZLY 550 EPS 4WD HUNTER - YFM5FGPHA ELECTRICAL 1
2011 GRIZZLY 5504WD - YFM5FGAL ELECTRICAL 1
believev is offline  
post #10 of 12 Old 07-08-2016, 03:55 PM
 
reogem's Avatar
 
Join Date: Aug 2011
Location: Northern WI.
Posts: 6,952
Thanks: 2,842
Thanked 3,055 Times in 2,105 Posts
Rep Power: 134
                     
550 and 700's use the same meter,
The diagnosis procedure is the same.

They do have different ECM.

Twin sister 16 Kodiak EPS 700 Dirty Egg Salad (Camo)
Grezzzless CVT 22g
26.5" Pitbull Growlers Uber XOR
STI HD1 Beadlock Wheels


Hers 16 Kodiak EPS 700 Camo
26.5" Pitbull Growlers Uber XOR
STI HD1 Wheels


2013 Ole blue 700
Putting out to Stud 21365 miles
360/120 CVT
26" ML XTRs
stocker wheels
grezzzless clutch.
reogem is offline  
post #11 of 12 Old 07-08-2016, 09:18 PM Thread Starter
 
believev's Avatar
 
Join Date: Nov 2014
Age: 41
Posts: 54
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 58
 
I was able to get into diagnostic mode finally. On mine - I had to set the kill switch to on. and then it lets me into diag mode.

I also unplugged and cleaned my dash connector. it had some corrosion. either way with the kill switch off- it does NOT go into diag mode, only with that kill swtich on


which is bizarre, but the problem is solved
believev is offline  
post #12 of 12 Old 05-04-2019, 01:15 AM
 
Beasley907's Avatar
 
Join Date: Feb 2019
Posts: 24
Thanks: 0
Thanked 5 Times in 2 Posts
Rep Power: 0
 
Can you post a pic of what to unplug on fuel pump harness?
Beasley907 is offline  
Reply

  Lower Navigation
Go Back   Yamaha Grizzly ATV Forum > Grizzly Forums > Grizzly Engine & Transmission

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome