Yamaha Grizzly ATV Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Yamaha Big Bear/Bruin/Wolverine ATV Discussion
    When the front plastics are on even unbolted and headlights not hooked up it will have a high idle and die out but if plastics are taken off it runs perfect, cant see any wires or cables being pinched and cant see any reason it could affect it, anyone run into this problem and find a fix?
  2. Yamaha Big Bear/Bruin/Wolverine ATV Discussion
    My BB leak appears to be at the point where the front drive shaft enters the gears (I don't know what that box is called). How do I remove the shaft and get to the seal? Some basic instruction would help. I think I have adequate access to the rear universal joint from the under the machine...
  3. Yamaha Big Bear/Bruin/Wolverine ATV Discussion
    Hi folks. This is a great forum and I have checked into it many times but this is my first post and ask. I have a much loved Big Bear I inherited from a prior property owner. As indicated in my title, the dealer thinks it's a 1999 and my manual says it is a YFM350FWSPL. I believe this is a...
  4. Yamaha Big Bear/Bruin/Wolverine ATV Discussion
    My 88 has been a bugger. Its picky. Replaced alot. Still starts only when it really wants too which doesnt make no sense. Starts first pull when its over 20 celsius. Any time its colder it wont. I dont get it.. Anyway. I noticed that the break switch behind the left hand lever is cut. Does this...
  5. Yamaha Big Bear/Bruin/Wolverine ATV Discussion
    Hi there! I have two Yamaha Big Bears that have been in the family for years. Went to register them for the first time and noticed my 96 Big Bear VIN comes up with VIN searches, but my 87 (I think) doesn’t.... Anybody have a VIN starting with JY33? VIN decoders say it isn’t a Big Bear.... thoughts?
1-5 of 5 Results
Top