Yamaha Grizzly ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 07 grizzly 700 dies at random times while riding. Used to happen only after riding awhile when it was hot but now it happens whenever. It will start to lose power like you shut the key off and start backfiring and usually start to come back to life and run fine for awhile then start again. Sometimes it gets bad enough it won't want to start back up until it sits for awhile.

I've checked and tried changing the coil with no luck.
I went ahead and changed the stator and updated the stator cover to an 09 model
Everything I've looked at has checked out fine.
Battery is good
Good spark plug and tried changing it after it happens with no luck
Anyone have any other ideas? I'm thinking could be a cdi possibly failing but hard to tell.
 

·
Registered
Joined
·
209 Posts
If it's spitting and sputtering and your reverse light is flashing on your speedo then it's your neutral switch assy 3GB-82540-01-00 and gasket 90430-10148-00
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
If it's spitting and sputtering and your reverse light is flashing on your speedo then it's your neutral switch assy 3GB-82540-01-00 and gasket 90430-10148-00
The reverse light doesn't flash. It's bypassed to ground. Was like that when I got it. So with it bypassed could that still cause it?
 

·
Premium Member
Joined
·
8,758 Posts
My 07 grizzly 700 dies at random times while riding. Used to happen only after riding awhile when it was hot but now it happens whenever. It will start to lose power like you shut the key off and start backfiring and usually start to come back to life and run fine for awhile then start again. Sometimes it gets bad enough it won't want to start back up until it sits for awhile.

I've checked and tried changing the coil with no luck.
I went ahead and changed the stator and updated the stator cover to an 09 model
Everything I've looked at has checked out fine.
Battery is good
Good spark plug and tried changing it after it happens with no luck
Anyone have any other ideas? I'm thinking could be a cdi possibly failing but hard to tell.
Makes sure that the fuel tank vent and the roll over valve are working properly.
Also check and clean the kill switch.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Makes sure that the fuel tank vent and the roll over valve are working properly.
Also check and clean the kill switch.
That was missing when I got it lol. Until I find the problem I just have a hose on it then I'll buy the valve. Someone said maybe a fuel pump going out? Not sure with how intermittent it is but maybe that's the next step?
 

·
Registered
2008 Grizzly 700 EPS Red
Joined
·
14 Posts
Makes sure that the fuel tank vent and the roll over valve are working properly.
Also check and clean the kill switch.
I agree on the rollover valve. Mine was dying randomly when i would let off the gas and slow down or even when isling for a bit. Swapped the valve with some K&N fuel filter from Summit Racing and it has been happening a lot less.
 
1 - 6 of 6 Posts
Top