Yamaha Grizzly ATV Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My friend dropped off his grizzly to repair because it will crank over and start and almost always immediately stall. Every once in a while it will run and idle for 15 seconds and stall. Sometimes it wont start at all, just turn over. No codes except for the EPS speed sensor, which I don't think is related. I have removed the throttle body and left it connected to check the spray pattern of the injector and it looked good, maybe excessive, but I have nothing to compare it to. I tested the TPS and it was 17&97 - good. I did not test the other sensors on the throttle body, but it would have a code if they were bad, right? I pulled the plug and it looked black and I ordered another, it will be here tomorrow. The spark did look acceptable on the existing one. There is no air filter in the air box, but it should still run. I am going to check the valves and replace the spark plug tomorrow, but am I missing something simple? I am very good at troubleshooting, but this has me thinking. I do have the service manual for the '07 but not the '08 like I have. Any help is GREATLY appreciated! Thanks fellas.
 

·
Just wanna ride!!
Joined
·
5,517 Posts
Welcome to GC. We have several trouble shooting gurus that will be along shortly.
 

·
Premium Member
Joined
·
5,696 Posts
Spark plug first.
 
  • Like
Reactions: mainehunter

·
Premium Member
Joined
·
7,910 Posts
While you have the spark plug out adjust the valves.
 
  • Like
Reactions: mainehunter

·
Premium Member
Joined
·
10,634 Posts
x-3 on the valves.
Did it sit all winter? and the gas go bad?
Being very careful, I have used short shots of starting fluid for hard starts.
For the age, if the valves have not been checked and they are out of adjustment, and the gas is bad, and the plug is fowled, you may have found the problems.
These low compression engines are sensitive to small problems that can add up.
 
  • Like
Reactions: mainehunter

·
Registered
Joined
·
5 Posts
Discussion Starter #8
The fuel was replaced with ethanol free gas by the last person who recently worked on it. I checked the fuel by running the fuel pump into a clear bottle and it is good.

I will adjust the valves, as well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
167 Posts
ya you are on the right track plug gas valves timing good luck
 

·
Premium Member
Joined
·
7,910 Posts
There really isn't any difference between the 07-08 your service manual is fine.
Couple other thoughts..
There have been reports of the fuel pump pickup falling off or the screen being clogged with dirt.
 

·
Registered
Joined
·
269 Posts
A few things that can be a pain, high tension lead rubbed thru, high tension lead pulled out of the cap a bit increasing the distance the spark has to jump & a bit of spark plug tip broken off in the cap making a bad connection, all the other replies should find the problem though.
 

·
Registered
Joined
·
167 Posts
you can look online for shop manual. I used one called skribid or something like that maybe spelled with a c instead of a k
 

·
Registered
Joined
·
5 Posts
Discussion Starter #14
Well, I just replaced the plug with the one below and it fired right up and ran for a while. Very low on fuel so I think I died because of that. Haven’t adjusted the valves yet, but will still probably check them. I am doing the fuel tank valve mod and filling it up with fuel tomorrow. I’ll report back.

Notice the difference in the plug.....???



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
269 Posts
Well, that's special! Good thing carbon build up didn't damage the head threads.
 

·
Premium Member
Joined
·
10,634 Posts
DrMud wins!
The plugs look to have different lengths, be care...and
Years ago a buddy bought a used grizz and it ran like crap, so I told him to get a new plug.
As the bike did not come with a book, he removed the old plug and bought a matching number and installed.
The bike still ran like crap.
I went over to help, and after a couple hours decided to install another plug, and as our 660 were the same, I used one I had on hand. I took one of mine as I knew the gap was correct.
It was then we determined he had the wrong plug, and the right plug was the answer.
 
  • Like
Reactions: mainehunter

·
Registered
Joined
·
167 Posts
what one is the right plug. why is one so much longer
 

·
Premium Member
Joined
·
7,910 Posts
07-08 700 use the CPR7EA9
09-13 700 use the LMAR6A9
14-18 708 is back to the CPR7EA9
 
1 - 18 of 18 Posts
Top