Yamaha Grizzly ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Good afternoon, I am new to this form and have been doing a lot of reading on the issue I am having and not having much luck fixing it.

I have a 2009 Grizzly 550 EPS EFI. About a week ago I was having an issue with it "clicking" multiple times when trying to start it. I would put it on the charger, let it charge for about an hour and it would fire up. Let it sit for a day or more and have the same issue. Until finally it wouldn't fire and just "click" multiple times form the starter solenoid. Knowing the battery was older I opted to replace that last week. Came home, and still having the same issue. Cleaned all the connections, still the same issues.

Thats when I got online and started doing some reading and trouble shot the starter solenoid. If I jumper it it sounds like the starter is spinning, however it will not start. Purchased a new solenoid...and still the same issue.

I am wondering if maybe the starter is bad?
 

·
Registered
Joined
·
217 Posts
Hey, Cdberent, welcome to GC !

From what you describe in your post the bike starts fine after a good charge but if you leave for a period of time it will not. The problem persists even with a new battery installed. In that case you may have something that drains your battery. What accessories you have installed? Are any of them powered all the time even when your ignition key is off?
If you own a multimeter:
With the key in the off position make sure you have 0.00 A current flow at the battery terminals. There should be a thread on here with the exact problem, I'll try and find it later.
And with those new batteries be aware that discharging them bellow a certain point will damage them. Post back with what you found. Good luck!
 

·
Registered
Joined
·
1,433 Posts
Welcome to GC. Too bad about the starting issue. When you say if you "jump it, it sounds like the starter is spinning", is the engine cranking over?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Every since I installed the new battery I just have the main cables hooked up and everything else disconnected. Haven't had a chance to put a meter to it but I'll give that a shot.

It does sound like the engine is cranking but it will not start when I jumper the solenoid.
 
1 - 4 of 4 Posts
Top