Yamaha Grizzly ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all- So yea, somewhere under 10 hrs on this rig, basically brand new, bone stock, only owner. It is currently in the shop for it's 2nd fuel pump replacement. This sounds like more than just bad luck. The tech mentioned maybe ran out of gas (?!), uh no. Or old gas, no again. Needless to say, makes me a bit worried getting too far out in the woods, which is the whole reason I bought these. (also have a '14 450, bought at the same time). Both times the indicator is that it blows the 15A fuse. Just posting here in case anybody has any ideas what could be happening. If this happens again, somebody at corp is gonna get a frickin earfull.
 

·
Premium Member
Joined
·
2,202 Posts
With the fuse blowing it could be a short in the harness or 2 bad pumps which would be rare.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hey thanks for replying. I was hoping to avoid the "H" word. Would a diagram help me to focus on a particular area of the harness?
 

·
Premium Member
Joined
·
5,697 Posts
So, have you done any wiring accessories? If yes what? Any water riding?

Ten hours on a 14'. What about mice on the wiring harness?

I had a whole box of rat poison packed to the inside of my breather intake one time in less than a couple of weeks.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
No mods, no accessories. I did not dig into it very far as it's covered under warranty, didn't want to give any reasons to deny a claim, hopefully the shop would notice mouse tracks and let me know. I'll definitely give it a good look-thru when I get it back from the shop. As for mud or water, sure some small time puddles and stuff, nothing like swimming or anything crazy.
 
1 - 5 of 5 Posts
Top