Yamaha Grizzly ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi Guys, I had my rad out while straightening my bent frame and got it all back together but I not sure if I lost the clips or if there are none to hold the top of the rad onto the plastic "dowels" it slides onto. There are 2 rubber bushings and I keep thinking I removed some kind of retaining clips when disassembling it. The dealer parts diagram doesn't show any. you have to pull the colored plastic off under the rack to see it and I couldn't do that at the dealer. lol if anyone knows for sure or can look at theirs I'd appreciate it!

thanks
al
 

·
Registered
Joined
·
104 Posts
Look at the picture. There are 2 clips (nr. 13) or aren't those the ones you are "thinking" about?
I'm willing to look under my plastic but ....... I'm not willing to take the rack off :wink2:

Rob
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Rob,
Thanks for that but those are for the fan bolts.
What I'm asking about would sit in front of rubber mount bushing #16 in diag
 

·
Registered
Joined
·
104 Posts
Sorry, I deleted my initial text of this post completely because I got a little bit confused and mixed things up.
Have to have a good look again at all the pictures and a look in the Service Manual.

But there is one thing I would like to know: which number ('model name") has your Grizzly? Is it one of the numbers listed on the 1st picture?.

Ignore the 2nd picture for now!

Rob
 

Attachments

1 - 5 of 5 Posts
Top