Yamaha Grizzly ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Anyone have any ideas what could cause this? I can spray carb cleaner in breather it will start and runs great. When you shut it off it will not start back without help from carb cleaner. It’s at shop now and they are struggling to find the issue. Mechanic said he can ground the injector manually and tap it on the frame repeatedly and it will start. Shop said CDI may be bad but no way to test it. Don’t just want to throw parts and money at it without knowing something for sure. All ground connections have been cleaned and checked. Any ideas would be great? Does anyone have a CDI that I could try or purchase? Stator has been replaced & TPS.
 

·
Grizzled
2014 Yamaha Grizzly 700 EPS
Joined
·
3,662 Posts
I know you have "kind of" mentioned this in one of your other threads, but it was a bit unclear when you had or didn't have error codes and what is the current situation?

What error codes are currently present?
 
  • Like
Reactions: mainehunter

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Not sure of error codes as Grizzly is at shop. Shop is scratching their heads not sure of problem. Before I took it to shop it was showing TPS code.
 

·
Premium Member
Joined
·
7,920 Posts
A Yamaha shop?
No codes??
Injector will not open with less than 7 volts. Popping the engine with starting fluid will cause the stator to supply the needed voltage to run.
Fully charge battery overnight
Check that battery connections are clean and tight
Check wire connections at the injector

In diagnostic mode run tests D9, D36 and D50 these test the injector and the injector relay.
 
  • Like
Reactions: mainehunter

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Shop works on all makes. Got a call in to find out what codes are now showing. Runs good after you start it with carb cleaner. Just not getting fuel at start up. Injector not opening to start, he said you can manually ground the injector repeatly tapping the frame and it will open and start. Ideas????
 

·
Premium Member
Joined
·
7,920 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Diagnostic test recommended has been run and checked good. Getting the proper voltage to injector, not getting the pulsating ground needed for injector to open at startup.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Got the new ECU in and it did not fix the starting issue. Tests have been done on the injector and checks good. What would cause the injector not to spray at startup? What controls this? Need help please.
 

·
Premium Member
Joined
·
7,920 Posts
Codes?

Battery is fully charged? Has 12.8 volts?

ECU is grounded properly?

Was the TPS calibrated correctly after installation?

Check that the intake air pressure sensor hose is connected without kinks?

Fuel injection system relay has tested good?

The injector wiring is good.
 
1 - 9 of 9 Posts
Top