Yamaha Grizzly ATV Forum banner

1 - 7 of 7 Posts

·
Registered
2012 Yamaha Grizzly 300
Joined
·
2 Posts
Discussion Starter #1
Recently purchased a 2012 Grizzly 300 and noticed it was jerking and slipping while driving at any speed. Air filter is clean, gas is fresh, new spark plug, changed tranny oil, replaced the belt and it hasn’t changed. It’s worse when I’m going up a hill and now not driving until it’s been diagnosed. Also makes a slap noise like something is hitting the inside of a case when slips. Loose chain? Does anyone have any thoughts on next steps?
 

·
Premium Member
Joined
·
7,790 Posts
Possible Causes include
Roller weigh/st flopped out of the channel
Secondary sheave stuck or sticking
Centrifugal clutch bad
Stripped driveshaft or axle.

Start by looking at the CVT for a flopped weight or possible secondary sticking.
here you can see the CVT assembly

Look around on that website for assembles that maybe the cause.
 
  • Like
Reactions: JOE96924

·
Premium Member
Joined
·
7,790 Posts
Please don't make multiple posts on the same issue. I see at least four posts.
The answers will be scattered and confusing.
 

·
Grizzled
Joined
·
3,559 Posts
Please don't make multiple posts on the same issue. I see at least four posts.
The answers will be scattered and confusing.
Thanks @reogem and agree so the other 3 threads have been deleted.

Welcome to GC @cmdueck. As reogem points out, a single thread only please as it is much more useful to you and those who follow behind you with a similar question. Thanks.
 
  • Like
Reactions: JOE96924 and reogem

·
Registered
2012 Yamaha Grizzly 300
Joined
·
2 Posts
Discussion Starter #5
Possible Causes include
Roller weigh/st flopped out of the channel
Secondary sheave stuck or sticking
Centrifugal clutch bad
Stripped driveshaft or axle.

Start by looking at the CVT for a flopped weight or possible secondary sticking.
here you can see the CVT assembly

Look around on that website for assembles that maybe the cause.
Apologies for posting the same question in a few categories. First time and wasn’t sure what to do.

Appreciate the feedback on the 300 and will look into all those possible causes.
 

·
Grizzled
Joined
·
3,559 Posts
Apologies for posting the same question in a few categories. First time and wasn’t sure what to do.
No worries and thanks for understanding. As a FYI, the 3 deleted threads had no responses when I deleted them so no info was lost.
 

·
Registered
Joined
·
5,470 Posts
What kind of engine oil did use?
 
1 - 7 of 7 Posts
Top