Yamaha Grizzly ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Recently we bought a 2013 grizzly 550fi mainly to plow and keep up with firewood, we've had no issues whatsoever for the two months I've owned it however the other night my son took it out for a ride, shut it down and it wouldn't start. I isolated the issue to the starter solenoid, went and purchased one the next day and installed it. Before hand I have to admit I did try and jump the two main terminals to try and get it home with no avail. Since then, new solenoid installed it will crank, immediately start and run for about 1-3 seconds only to quit. Taking a closer look I found two of the 4wd wires chaffed and the positive to the fan, repaired them correctly also. Since then I found a comprehensive technician manual online ( how I figured out what each wire was) and have begun to try and trouble shoot the problem with no luck. I have spark, compression, and plenty of fuel from the injector. To add to my delma, the multifunction meter assembly no longer projects any values with key on, only for a brief second with the engine fires until it dies. If anyone can help I would greatly appreciate it. I'm definitely feeling the pressure even more so now with winter showing it's signs to the great north east. I truly appreciate any help at all at this point I'm kind of stumped.
Zach
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
UPDATE: I did some troubleshooting today and realized if the start button is pushed and held it the machine will continue to run until it is depressed. Any help at all would be greatly appreciated!! Thanks Zach
 

·
Premium Member
Joined
·
12,794 Posts
I would clean the switch, do a full tune-up including valve lash adjustment for starters.
 
1 - 3 of 3 Posts
Top