Yamaha Grizzly ATV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Help
New battery keeps going dead over 2 or 3 days. Charging circuit works. Hooked up test light between negative battery cable and post. Faint light when key is off which tells me it something is drawing current. Begin to pull fuses to see if light would go out. As soon as i pulled the EPS fuse the light went out. Any suggestions would be appreciated before I start pulling covers off.

Thanks
Danny
============================================================
Update:
Bought a manual today.
Disconnected every wiring harness plug which there are many and came to the two that goes into the power steering control module. when I disconnected either of those the short went away. They are bigger wires one is the negative (black) and the other (brown/red) going to the fuse. It changes to green going into the module. Tempted of opening the module up but not worth it. Expensive part if I break it. I guess I will keep it on the trickle charger like I have been.

Any other thoughts on this is appreciated or if you have disassembled one of these please chime in.
Danny



Motor vehicle Automotive design Vehicle Gas Automotive exterior
Motor vehicle Hood Gas Auto part Automotive exterior
 

·
Premium Member
Joined
·
12,794 Posts
Welcome from Colorado.
I suspect a rubbed/chaffered wire. I'm not sure on the wiring so suggest a f.s.m. for your bike from our member at 501parts.com
 
1 - 2 of 2 Posts
Top