Yamaha Grizzly ATV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
I noticed this during my trip to Colorado and again a couple weeks ago while riding here. The indicator says my 4WD is on all the time. I can get it to go off at times but it comes back on. I haven't lifted the quad up to be sure but it definitely feels like it's actually on and not just the indicator. Anyone else had this happen? Any thoughts would be appreciated.
 

·
Registered
Joined
·
867 Posts
Could be your switch, Yamaha has a recall on some of the 2014 and 15 Grizzlys. Get your serial number and call a dealer with that and they should tell you if your machine qualifies. My 2015 did and they ordered a switch and installed it and I was good to go. Good luck!!
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #3 ·
Could be your switch, Yamaha has a recall on some of the 2014 and 15 Grizzlys. Get your serial number and call a dealer with that and they should tell you if your machine qualifies. My 2015 did and they ordered a switch and installed it and I was good to go. Good luck!!
Awesome. Great to know. Thank you Blklab
 
  • Like
Reactions: Blklab

·
Just wanna ride!!
Joined
·
5,541 Posts
Look here...
http://www.grizzlycentral.com/forum...-drive-kicking-out-not-responding-switch.html
I’d try this first and then I’d be looking at the servo motor if that doesn’t work. If your machine qualifies for the new switch, it still shouldn’t be an issue to get it. This is just a quick “do it yourself” check to see if the switch is your problem. I’ve done this on two different machines and haven't had a problem out of either one since.
 
  • Like
Reactions: BaldEagle

·
Registered
Joined
·
159 Posts
Discussion Starter · #5 ·
Thank you all. I had called the dealer this morning before getting back on here and seeing the post from OKBear. The dealer said it's not under recall but a service call (or note or something). I guess the difference is under recall they call me and tell me to bring it in and under a service call they will fix it but only if you call with a problem. Anyway, it's going to get fixed for free once the part comes in. Thank you all for the helpful posts.
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #6 ·
Yamaha rocks. (but we all already knew that). The replacement switch arrived on Thursday and they fixed on Saturday morning. No charge. Not bad for a four year old quad. Thanks again Okbear and Blklab for the feedback.
 
  • Like
Reactions: Blklab

·
Registered
Joined
·
105 Posts
I would like to thank Grizzly Central for informing me about the 4WD switch "part update." I called my dealer when this 4WD switch issue first came up. He said not to worry about it unless there was a problem. After 2000 miles on my early 2016 Grizzly the 4WD servo would cycle in and out with the indicator symbol blinking at start-up. Pushing the switch in and out would stop the cycling. The 4WD switch was replaced by the dealer a few days ago. THANK YOU YAMAHA. The new switch takes a little more pressure to push it in. I would urge all of you with the affected VIN numbers to get the 4WD switch replaced as I suspect most of these switches will eventually go bad. There may be a time in the future when Yamaha no longer feels responsible for replacing the 4WD switch.
 

·
Registered
Joined
·
867 Posts
Yamaha rocks. (but we all already knew that). The replacement switch arrived on Thursday and they fixed on Saturday morning. No charge. Not bad for a four year old quad. Thanks again Okbear and Blklab for the feedback.
Glad it all worked out. That's what I like about GC , you meet a lot of good people and go on some awesome rides and almost always get the help you need if you have a problem. :rocker
 
1 - 9 of 9 Posts
Top