Yamaha Grizzly ATV Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
I have 2016 Grizzly with 1300 some miles on, I bought it new in August of 2016. The four wheel drive seems to work fine if I turn it on. However, when the switch out on the off position, the four wheel drive indicator light on the screen randomly comes on and goes off. I turned it on and off repeatedly over the weekend and it helped some, but it's not fixed.

Any ideas? Start with the switch itself?
 

·
Just wanna ride!!
Joined
·
5,517 Posts
  • Like
Reactions: aht_six

·
Registered
Joined
·
97 Posts
Discussion Starter #3 (Edited)
okbear, thanks for the quick response and the link. I took my switch apart and it didn't look too bad. I cleaned it up, polished the contacts with some Scotch-bright and put on some fresh di-electric grease. I took the Griz for a test drive, and now all seems well.

Thanks again for the help.

The attached picture is before I cleaned up the switch.
 

Attachments

·
Just wanna ride!!
Joined
·
5,517 Posts
okbear, thanks for the quick response and the link. I took my switch apart and it didn't look too bad. I cleaned it up, polished the contacts with some Scotch-bright and put on some fresh di-electric grease. I took the Griz for a test drive, and now all seems well.

Thanks again for the help.

The attached picture is before I cleaned up the switch.
Great! I have a friendly Yamaha dealer not too far away. I'm going to contact them and see if they'll just give me the new switch in the event I have further issues. I can't see Yamaha wanting the old ones back considering they know about the issue. They would know about the fix if they'd visit GC every once in awhile! lol
 

·
Just wanna ride!!
Joined
·
5,517 Posts
double post
 

·
Registered
Joined
·
175 Posts

·
Registered
Joined
·
168 Posts
okbear, thanks for the quick response and the link. I took my switch apart and it didn't look too bad. I cleaned it up, polished the contacts with some Scotch-bright and put on some fresh di-electric grease. I took the Griz for a test drive, and now all seems well.

Thanks again for the help.

The attached picture is before I cleaned up the switch.
I had issues for the last couple months with this and have cleaned all my connections and still had the issue. Cleaning and removing the contacts inside the switch is what finally fixed it for me
 

·
Just wanna ride!!
Joined
·
5,517 Posts
I did this cleaning on my atv, the issue came back 6 months later. I am going to contact my local dealer and see about the new switch also.
I just contacted a local dealer where my brother-in-law is tight with the owner. Waiting on a call back to see if they'll just give me the switch. At least I'll have it in case I have further issues that way.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #10
I called my dealer today, I know them very well. I've bought many motorcycles and ATV's over the years. The Service Manager told me they have the part in stock, and my 2016 is part of the service bulletin. He told me to bring the ATV in, and he would swap out the switch while I waited, should take about 20 minutes.
 
  • Like
Reactions: Madkawi750

·
Registered
Joined
·
1,399 Posts
I called my dealer today, I know them very well. I've bought many motorcycles and ATV's over the years. The Service Manager told me they have the part in stock, and my 2016 is part of the service bulletin. He told me to bring the ATV in, and he would swap out the switch while I waited, should take about 20 minutes.


I contacted Yamaha about my 2016 and they said "nope, don't see any your machine s/n on any list" seems weird some are good and some are not.



2016 Grizzly 700 le,
26 Bighorns on Stock wheels.
1 1/2" custom tip, EHS fuel controller.
1.5mm shim and Dalton Metallic Red secondary, 224 watt 12" LED bar.
 

·
Registered
Joined
·
175 Posts
I just contacted a local dealer where my brother-in-law is tight with the owner. Waiting on a call back to see if they'll just give me the switch. At least I'll have it in case I have further issues that way.
I contacted my local dealer (its the same place I bought them from so they have records) He said he will order them and call me when they come in (about 3 or 4 days). Then I can come get them and install them myself if I want. Which is good, I didn't want to load them just to wait 30 min and take them home again.
 
  • Like
Reactions: okbear

·
Registered
Joined
·
168 Posts
I contacted Yamaha about my 2016 and they said "nope, don't see any your machine s/n on any list" seems weird some are good and some not
I contacted my dealer about the problem and before looking up my vin he said most 16s have this problem. I might call another dealer if your having issues

He's giving me the switch in return for my old 1 without having to bring my quad in
 

·
Registered
Joined
·
97 Posts
Discussion Starter #14
I took my Grizzly to the dealer today, they swapped out the 4WD switch while I waited. Only took a few minutes. Mine is 6 months out of warranty, but the switch was covered no charge.
 
  • Like
Reactions: nhwylee and it400
1 - 14 of 14 Posts
Top