Yamaha Grizzly ATV Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
this thing acts like the reverse rev limiter is stuck on in every gear even park and nuetrel, it seems to only be rpm limiting not speed.
tried bypassing difflock [cut white wire on third connector down on cdi] and reverse limiter(grounded green wire w/ white stripe) like other post on this forum said to do to bypass the two and it is still doing the same thing. it only runs like 12 mph in low and 20 mph in high. sounds just the same as it did when it hit limiter in rev. runs smooth up to a certain rpm then more throttle and it starts breaking up even more throttle and it breaks up and pops more violently, 2002 660 Grizzly
 

·
Registered
Joined
·
1 Posts
I have the same problem. Did you find the issue?
my bike will start but when I hit the gas it does the same as it would do to govern the reverse speed. When I let the gas go it dies.
 

·
Registered
Joined
·
1 Posts
I have an 07 grizzly 350, I'm have a similar problem. A couple months ago the reverse light was coming on and it had no power, I grounded the green wire with the white stripe and boom everything worked perfectly again, I rode long distance trips as usual, but after I put on roughly 100 miles I took a short ride to town and it bogged down I couldn't fix it on the trail so I limped it home. It starts great and idles great but when I give it gas it spits and sputters, it never does completely but will not rev up in gear or neutral. Please help, I have a ride planned for Thursday but I'll have to cancel if I can't figure this out. I know it has to be something simple but am not a small engine guy, I am a carpenter! Lol
 

·
Premium Member
Joined
·
12,259 Posts
Welcome from Colorado.
I think you need a full tune-up including checking the valve lash and timing.
It will be good for you to start a new thread for best help, timely help focused on your problems with more information as we try to help you stay on the trail.
 
1 - 5 of 5 Posts
Top