Yamaha Grizzly ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My Grizzly bogs out at 30mph, it looses power and pops out the carb. I have been told the carb needs to be rebuilt but it's brand new, I was told the rev limiter is bad but I don't think it has on(not sure) I've been told the timing is bad but that would mean it would run rough all the time Anyone else have this problem?
 

·
Registered
Joined
·
5,116 Posts
Is it a OEM carb or Chinese Ebay special?
The cheap Chinese specials are a hit or miss at best. I would start by cleaning, rebuilding a d installing the OEM carburetor. It's a much better quality carburetor. Use a soaking/dunking carb cleaner like Solder Seal's Carb Medic or Hydro Seal II. The spray can carb cleaners just can't do the job for really gummed up carbs.

Has the valve clearances ever been checked or adjusted? If not, get it done.

Check the carburetor adapter boot for cracks or tears. This is the part between the carb and cylinder head.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I got the carburetor installed at a dealership in Upper Michigan who told me that the carb I had was beyond rebuilding because it was too worn out.
 

·
Registered
Joined
·
15 Posts
Can you post a picture of the carb? If the dealer claims they replaced it, I can almost guarantee they got the cheapest garbage possible. Also if you can, post a picture of your fuel filter.

When I got my grizzly it would run hot after about 20 minutes and the oil temp light would come on. Also, it would pop and sputter like crazy. Once I pulled the carb and put a rebuild kit in it it ran much better and once I changed the oil she was a brand new machine.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I ordered a rebuild kit for the new carb. I also found the spec's on the valves so I will tackle it this upcoming weekend. I did save the old carb if I need parts. If this does not fix the problem, dou you think the ECM?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I did forget to mention this happened all of a sudden. The wife and I went on a ride with a group and on the way home it started acting up doing as described. I had a vehicle do something similar and it turned out to be the ECM, but I it's a huge difference between an 4 cylinder car engine and a single lung ATV engine.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Ok I dug into the machine and found a couple of things wrong. I the choke cable plastic threaded part that goes into the carb was broke. I also found the intake boot was cut by the hose clamp so that brand new boot is junk. The valve lash is good and at the high end of the specs. I also noticed the throttle cable is worn so I ordered a new one of those too. I installed a new spark and a new coil while I was at it. So just waiting on the parts and it should be running by Monday at the latest. I thank you all for the help! I really learned a lot reading threw the posts from others too. I tell ya at $110 per hour I learn all I can to fix this thing myself.
 
1 - 8 of 8 Posts
Top