Yamaha Grizzly ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
ok so here's my story. 2014 griz. Bought used 2 years ago. it always had this slight clicking in the rear usually only turning (I forgot if it was turning left or right). So 2 weeks ago after reading many threads I figured it must be the cv axles. the boots weren't torn and there wasn't any play in them. I did the left side first where I thought I heard the noise coming from. After installing the new axle it made the noise worse!!! Now it does it just driving straight and seems louder. I replaced the other side a week later hoping it would some how fix it which it didn't. I have new wheel bearings on the way but would bad bearings make a loud clicking noise? Also I jacked up the quad. spun both the front and rear tires and cant get it to make a single click noise. the tires also have no wiggle to them which is why I didn't order the bearings in the first place. Rear diff is also nice and tight bolted the frame. Running out of threads to read dealing with clicking noises. Any other ideas?
 

·
Registered
Joined
·
66 Posts
Have you checked the bushings in the knuckle? on the rear
 

·
Premium Member
Joined
·
5,697 Posts
Grab hold of a tire on the top jerk it in and out, if it clicks you have a hub machined to deep, bearing is popping from one side to other, usually does not occur unless turning. Not sure if Yami ever issued a recall on this, had three of mine fixed, and the fourth was on back order, dealership closed, never happened. This was on my 2015.

That parargraph was a full day of back and fourth with my dealership to resolve....thread on here somewhere about it.
 
1 - 3 of 3 Posts
Top