Yamaha Grizzly ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
So finally got to take my 02 grizzly 660 out for a decent ride after the rebuild and had some issues. First off rode for about 45mins and stopped and took a break. Headed back and about 5 mins into the ride the temp light came on.. decided to keep riding since it was slow riding to that point and knew I had faster riding coming up that I could get some good airflow through the radiator hoping that would cool it down, well it didn’t and I stopped and shut it off and could hear the coolant bubbling and it was puking out the overflow hose. So now I’m worried about what kind of damage was caused by that. Next thing I went to start it back up and the battery was dead.. was a brand new fully charged Yamaha battery.. so now I’m guessing it’s either the voltage regulator or stator.. As far as the overheating issue it has a brand new radiator and coolant was full. Both hoses seemed to get warm when I checked them so I’m guessing it’s not the water pump and leaning towards thermostat. Other than that it ran great but the clutch area seemed noisy like a rattle but I never rode it before with a clutch that actually worked since after I bought it I took it apart to grease it and it was packed with mud. So I’m guessing it’s just normal noise from the rollers moving and all the moving parts? I just don’t have anything to compare it to. Any thoughts? Let me know thank you
 

·
Premium Member
Joined
·
10,180 Posts
The weights rattle around when the movable pulley changes force against the belt...and during back-shift on a steep hill the rear tires get light to the ground, kind'a' a hop and skip slide feel.
Wouldn't pull start?
 

·
Premium Member
Joined
·
10,180 Posts
Probably didn't hurt it if ran OK going home, might not have had it full of coolant.
 
1 - 5 of 5 Posts
Top