Yamaha Grizzly ATV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I had to jump start my 2013 Grizz 550 because battery was low and snow coming. It jumped fine but when I went to raise the plow, the winch did nothing, no clicking nothin. Checked all the battery connections, all were clean and tight. When running, it's charging at 14.20 volts. Suggestions?
 

·
Registered
Joined
·
2 Posts
Is only the winch not working. Maybe check its fuse or its switch or connections to the winch.
With a volt meter check for power at the winch and work your way up the line.
 

·
Grizzled
2014 Yamaha Grizzly 700 EPS
Joined
·
4,112 Posts
Fully charge your battery and then have it load tested. Trying to troubleshoot electrical problems with a suspect battery will end with a misdiagnosis. Even with the stator/rectifier putting out 14.2V, it takes quite a while of running to get your battery back to a fully charged state. You should use a low amp battery charger and charge it for the day or what ever it takes to fully charge it and then start troubleshooting.
 
  • Like
Reactions: reogem

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
I found 1 blown 10 amp fuse, replaced it. Winch still dead, put on charger for now.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
Load tested battery, it's got 1 dead cell so I guess it's new battery time. It does in my grandson's electric car though:rolleyes:
 

·
Premium Member
Joined
·
8,877 Posts
The battery is the power source for all electrical equipment on the Yamahas. The stator basically only charges the battery.
 
1 - 7 of 7 Posts
Top