Yamaha Grizzly ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have an 05 660 Grizzly and I am having problems. When trying to start it struggles to turn over. I put a new starter in but same result. The starter has been tested and spins freely when off the bike. I have a vid of what it sounds like jumping from the battery to the starter but can't seem to post it. Basically it sounds like a car with a dead battery. Rar...rar. The battery tests fine. Any ideas?
 

·
Premium Member
Joined
·
9,245 Posts
The ground can be weak from corrosion or a weak connection, also check the battery connections. These cause low voltage.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
When we jumped from the battery to the starter motor the wire we were using got very hot fast. Lots of power going going to the starter. Almost like something internal is slowing or jamming?
 

·
Premium Member
Joined
·
9,245 Posts
One hot wire to the starter, using the bike ground (possibly weak) may be your problem.
 

·
Premium Member
Joined
·
2,147 Posts
Try doing a voltage drop test on it . You can Google how to do this and it will tell you a lot about the health of the starting system... grounds , cables etc.
 

·
Registered
Joined
·
782 Posts
hard starting

Try doing a voltage drop test on it . You can Google how to do this and it will tell you a lot about the health of the starting system... grounds , cables etc.

Might have an issue with decompression mechanisum stuck


My 700 burned the post right right off battery. Decompression pin on mine was broken in half.
 

·
Registered
Joined
·
782 Posts
1 - 8 of 8 Posts
Top