Yamaha Grizzly ATV Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone new here. I have a 2014 450 grizzly. Little backstory my kids ran it through some deep water and it’s been sitting for quite a while. We did an oil change, new park plug, new carburetor and battery and it starts and runs now but doesn’t seem to want to go over 10-12mph and sound like it is running/idling high. My husband has tried to fix it but we are unsure where to go from here any help would be great.
 

· Premium Member
Joined
·
9,744 Posts
@Katie84 You should or have the CVT serviced. They usually have grease inside that gets contaminated with silt/mud when flooded.
 

· Premium Member
Joined
·
13,028 Posts
Welcome from Colorado.
If the c.v.t. cover is full of water the belt will slip and the grease will turn hard/thick preventing the weights from moving in the channels.
Get a f.s.m. from our member at 501parts.com to learn what's in the cover, its not too complicated and we are here to help you learn and getter fixed.
Here is a video of how the c.v.t. parts work as a system:
 

· Registered
Joined
·
1 Posts
Welcome from Colorado.
If the c.v.t. cover is full of water the belt will slip and the grease will turn hard/thick preventing the weights from moving in the channels.
Get a f.s.m. from our member at 501parts.com to learn what's in the cover, its not too complicated and we are here to help you learn and getter fixed.
Here is a video of how the c.v.t. parts work as a system:
Interesting reading Jim, thanks from NZ.
 
1 - 5 of 5 Posts
Top