Yamaha Grizzly ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I changed the wet clutch on my grizzly 600 and since then it makes loud noises and when I put it in neutral it makes it but if i rev it it stop making wierd clutch noises and when it in idle it makes it again and when I put it in gear it makes it but louder and when i rev it stop making wierd clutch noise but the second it reaches the idle it makes it but before it wasn't making the noise
 

·
Premium Member
Joined
·
9,851 Posts
Welcome from Colorado.
Check to see if the one way works right.
see if the primary will easily turn counter clock-wise, and locks to the crank going clockwise.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It turn easily counter clockwise and it lock the crank when i turn it clockwise and it wierd because I put a brand new one way bearing
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
It turn easily counter clockwise and it lock the crank when i turn it clockwise and it wierd because I put a brand new one way bearing
 

·
Premium Member
Joined
·
9,851 Posts
It turn easily counter clockwise and it lock the crank when i turn it clockwise and it wierd because I put a brand new one way bearing
That's the way it's designed, so the bearing is OK.
I would make damn sure the pulleys are good, then go back into the wet clutch cover to have a look.
 

·
Premium Member
Joined
·
7,728 Posts
It turn easily counter clockwise and it lock the crank when i turn it clockwise and it wierd because I put a brand new one way bearing
@Alex-F ..Welcome to GC from Wisconsin.

Did you install Yamaha parts? Specifically the one way bearing. Cheap Chinese one ways are junk out of the box.
 

·
Registered
Joined
·
5,443 Posts
@Alex-F ..Welcome to GC from Wisconsin.

Did you install Yamaha parts? Specifically the one way bearing. Cheap Chinese one ways are junk out of the box.
x2.
This is the first question that came to my mind.
 
1 - 7 of 7 Posts
Top