Yamaha Grizzly ATV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
514 Posts
Discussion Starter · #1 ·
OK so went to take quad (2013 grizzly 700 Eps) to work this morning turned key on pushed the button just a click. Tried this again same thing fig maybe I left key on and battery was dead put it on my trickle charger till lunch. Came home charger said charged tried to start it and same thing. This time I noticed on the lower left where the trip meter is there was a 12 does that mean anything? Came home from work and wanted to check fuses pulled the cover off and fig I would try one ,ore time and it started I started it 3 or 4 times all the same like normal. Has this happened to anyone of anyone point me in a direction on what to check
Thanks

Sent from my SM-T350 using Tapatalk
 

·
Grand High Inquisitioner
Joined
·
990 Posts
Make sure battery terminals are clean and tight. Maybe take the cables off, hit them with a wire brush, reinstall and tighten.
Probably just moving things around messing with it made a better connection so that's why it started working again.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top