Yamaha Grizzly ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 07 450 grizzly that I bought new . and the issue that I'm having is when I'm running the machine open. It starts to spit and sputter around 45-50mph. Almost like a limiter. But I never have had this issue before. Could it be belt wear, clutch wear?? Any ideas out there?
 

·
Premium Member
Joined
·
9,288 Posts
I bet the engine needs a complete tune-up.
I've seen this before with identical machines when one runs better than the other. Running one by itself, the difference is hard to notice. Generally I've found weak performance is from a few different small problems added together.

Thick grease in the primary keeps the weight in tight to the center of shaft axis and the engine gets to max rpm at a lower speed.
Valves slightly out of adjustment retard engine performance, then including an old plug to the mix not lighting the fire as well, and the result is reduced performance.

I've found it better to take the time and get everything back like it needs to be.
 

·
Registered
Joined
·
3,872 Posts
If the throttle response and starting is feeling good at all other rpm ranges and idle I bet you could get away with a little Sea foam in the fuel and a new spark plug.
If this doesn't help I would follow ridgeway and get valves done and a service of the clutches .. I have seen many times in carberator fuel systems just a does of seafoam clean out the gunk and free it up
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I have taken carb out and cleaned it . I have change the plug and still no difference. That's why I was thinking belt or clutch. Thanks guys for the tips. I will ck into them.
 
1 - 5 of 5 Posts
Top