Yamaha Grizzly ATV Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
1,241 Posts
Discussion Starter #1
@okbear had a great post here about how to use GC to host your images using the album feature on this site: http://www.grizzlycentral.com/forum/pictures-videos/93258-posting-pics-using-bb-code-gc-your-thread.html

But what if you don't want to mess with adding an image to an album, especially if it's just for one image for a specific reply to a post? I figured out a simple way to use the site to host your image, have it displayed full size, and do it all within the features of a single post.

This is how I do it using full version site, Chrome browser, on Android phone. But since it's browser based the steps should be identical on Safari on iPhone, or any browser on computer.

Keep in mind that the first many steps are just what you do anyway for the regular attachment of images anyways. It's only the last few steps that are additional for using the attached image for embedding right into the post as full size.

First thing to do is go to preview post so you can get to advanced options to attach images with the "paperclip"


Click on the paperclip symbol:


Click on "choose file" and select the image you want to use


Then click on upload


Then click-hold on the image you just uploaded and copy the link address.








Delete the start of the url and then paste in the link address you just copied:








So there you have it. Images hosted within the same thread they are used in, while also being viewed full size in line with the text and no need to click on the thumbnails to view individual images.

That is how I did this entire post.

I'll take a quick pic with my cell phone of the wood stove I'm sitting by and post it right after this post, to show how it looks in a simple post.
 

Attachments

  • Like
Reactions: it400 and okbear

·
Registered
Joined
·
1,241 Posts
Discussion Starter #2
Here is the wood stove. Image both hosted here and showing full size.

 

Attachments

  • Like
Reactions: okbear

·
Registered
Joined
·
5,537 Posts
Your website view is completely different than mine. I don't see half of that. I have no options for posting, no reputations, no "thanks" buttons....nothing except the orange colours.

I am also using Chrome app on Android phone.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #4
@dezz, I always go to the menu and click "exit enhanced mobile view". Then I get the standard mobile view, and click menu there, to get the option to go to full version:


This gets me to having the full version on my phone and all options available. But it still is quite compatible with the phone screen and can zoom in and out to my liking. Then also looks the same when I'm on a computer.

It should keep this as your view setting for 30 days
 

Attachments

·
Registered
Joined
·
5,537 Posts
My menu screen looks exactly like that. But got nothing else.
When I go to the bottom of the page I see a Full Version button, a Log Out button, and a Use Enhanced Mobile View button.
When I click on Full Version, the screen blinks, but nothing changes.
 

·
Registered
Joined
·
2,100 Posts
My menu screen looks exactly like that. But got nothing else.
When I go to the bottom of the page I see a Full Version button, a Log Out button, and a Use Enhanced Mobile View button.
When I click on Full Version, the screen blinks, but nothing changes.
Weird. I don't have a home computer either. All I use is a an old Sony Z3 phone, but I have same options, and see the same things as wheelsquad posted.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #7
My menu screen looks exactly like that. But got nothing else.
When I go to the bottom of the page I see a Full Version button, a Log Out button, and a Use Enhanced Mobile View button.
When I click on Full Version, the screen blinks, but nothing changes.
I tried my wife's phone, hers did exact same thing as you are describing. Clicked "full version" a 2nd time, and then it went. Had to do the exact same 2X thing for the Honda site too.
 

·
Registered
Joined
·
5,537 Posts
I tried my wife's phone, hers did exact same thing as you are describing. Clicked "full version" a 2nd time, and then it went. Had to do the exact same 2X thing for the Honda site too.
I took your advice and tried it more than once. I actually tried it about 10 times. No go for me. Not a thing changed.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #9
I took your advice and tried it more than once. I actually tried it about 10 times. No go for me. Not a thing changed.
Strange. I've been able to use any of the 3 GC site versions on Android/Chrome since the day I got a smartphone.

I'll play around and see if I can do the same thing through the other versions.

Also realized there are other ways to accomplish the same method of hosting and embedding images in the same thread. One of them being you can just attach images and create the post, then go back and copy the url for each attached image, and edit your post with those url's to embed them right into the post.

Basically, you can attach the image and once you do, it's like you have created a link for it like everyone used to have with photobucket, then use that url as you would have then.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #10 (Edited)
I took your advice and tried it more than once. I actually tried it about 10 times. No go for me. Not a thing changed.
Strange. I've been able to use any of the 3 GC site versions on Android/Chrome since the day I got a smartphone.

I'll play around and see if I can do the same thing through the other versions.

Also realized there are other ways to accomplish the same method of hosting and embedding images in the same thread. One of them being you can just attach images and create the post, then go back and copy the url for each attached image, and edit your post with those url's to embed them right into the post.

Basically, you can attach the image and once you do, it's like you have created a link for it like everyone used to have with photobucket, then use that url as you would have then.
So here I'm trying it in "Enhanced Mobile View" where it will at least let me attach an image.

I used the paperclip symbol at the top to attach this image of a mint XL75.


Once it was attached, I did a hold-click on the image and selected Open Image in New Tab


Then I went to that tab and copied the url


Then I pasted that url with the brackets around "img" before and "/img" after





Let's see if this worked...

Edit: yep it worked, did it all through the "Enhanced Mobile View" and added the embedded images of the step by step instructions.

I don't use tapatalk though so not going to attempt that one.
 

Attachments

·
Just wanna ride!!
Joined
·
5,517 Posts
Awesome post. I’ll have to play with this method some but I think it’s sticky worthy as it clearly works.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #12
Awesome post. I’ll have to play with this method some but I think it’s sticky worthy as it clearly works.
It works well for the simple one-off pics you want to have in a post but don't necessarily want to have to save in a separate album. But for the pics a guy would want to save long term anyway I will still use the GC albums like you showed, or some other host (like Google Photos that I use).

Learning the capabilities of the attached images being able to be hosted and embedded in the same post, I would think that @VS_Goose would be able to add a feature in the "embed photo" button that gives you an option just to attach the photo that you want to embed. Basically do it all in one seamless step. The hosting and embedding capabilities are there, just combine them into one. Have it be a button no matter what view you are in too.
 
  • Like
Reactions: okbear

·
Premium Member
Joined
·
331 Posts
It works well for the simple one-off pics you want to have in a post but don't necessarily want to have to save in a separate album. But for the pics a guy would want to save long term anyway I will still use the GC albums like you showed, or some other host (like Google Photos that I use).

Learning the capabilities of the attached images being able to be hosted and embedded in the same post, I would think that @VS_Goose would be able to add a feature in the "embed photo" button that gives you an option just to attach the photo that you want to embed. Basically do it all in one seamless step. The hosting and embedding capabilities are there, just combine them into one. Have it be a button no matter what view you are in too.
Unfortunately the Mobile view lacks a lot of site functions as the mobile view is simply a viewer to help decrease load times and operate better on mobile devices. The main software (vbulletin) operates with a lot more capacity and ability.

While I can appreciate you thinking very highly of my abilities, to have the EMV (The new mobile view) be able to do that requires a lot of code and a different department to operate that.

The embedding option (the so called one stop shop) is only available on the desktop view as the attachment manager operates its own way.

Props to wheelsquad for finding and posting that work around to embed your images directly into your post. I may be able to bring this to the EMV team and see if that is something we can implement in the future.
 

·
Premium Member
Joined
·
331 Posts
I've sent this up to that team. We'll have a look and see if its something we can put in place here, and all the other forums. Thanks for the suggestion!

Case# 2851787
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #15
I've sent this up to that team. We'll have a look and see if its something we can put in place here, and all the other forums. Thanks for the suggestion!

Case# 2851787
Hey goose, any progress on this?
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #17
This was resolved back in Feb 2018. Is it not?
I was thinking more along the lines of integrating the method I described into the embed photo button.

Basically, when you go click on the embed photo button, instead of just having the option to paste a link in, also have an option to upload a new photo right there, so behind the scenes it uploads and hosts the photo, while generating the link to embed. For the desktop view.

I had misread earlier what you said you would bring forward to the team as that. Where what you were actually saying was for the EMV, and sounds like you got that resolved, so thanks (even though I never use EMV, at the time I figured out the EMV attaching and embedding for those that do)
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #18
I was thinking more along the lines of integrating the method I described into the embed photo button.

Basically, when you go click on the embed photo button, instead of just having the option to paste a link in, also have an option to upload a new photo right there, so behind the scenes it uploads and hosts the photo, while generating the link to embed. For the desktop view.

I had misread earlier what you said you would bring forward to the team as that. Where what you were actually saying was for the EMV, and sounds like you got that resolved, so thanks (even though I never use EMV, at the time I figured out the EMV attaching and embedding for those that do)

@VS_Goose, like this:



 

Attachments

·
Premium Member
Joined
·
331 Posts
Ah I see what you mean now.

The insert Image icon is simply for inputting links. You need to use the paperclip above it to upload images from your computer. The paperclip is your attachment manager.

They have separate functions and cannot be merged.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #20
Ah I see what you mean now.

The insert Image icon is simply for inputting links. You need to use the paperclip above it to upload images from your computer. The paperclip is your attachment manager.

They have separate functions and cannot be merged.
Ok, then how about in the attachment manager have it obvious to have the link displayed that can be copied and placed with the embed image tool? Basically what I described in my first post in this thread but without having to hold on or right click on the attached photo link to get the url for it.

Not having an integrated built-in tool isn't a big deal for me, as the method I posted is pretty straight-forward for me. But I know for the less computer / smartphone literate average user, following this method or just embedding photos in general is a little on the challenging side.

And while I understand when you say they "cannot be merged", I guess I did think high enough of your skillset and as being the IT guy behind the scenes on these sites, to be able to make a feature that allows you to upload to host a photo and embed all in-line with a post in one feature. Basically if you go back to my post #1, that is what this method does. But it takes knowing how to get the image url from the attachment manager, and then knowing to go back and put that url into the embed image button. But it is really nice because it doesn't rely on some external site or album to host the image for you. I would think a new button with a script that runs to do that could be made.

But what do I know, I'm just a mechanical guy??
 
1 - 20 of 31 Posts
Top