Yamaha Grizzly ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Submerged my 700 eps again, yes again. First time drained all the fluid, removed plug and it turned over just fine. Put 100 miles on it since.

this time i pulled the plug and it turned over 2 or 3 times, now it will not turn over. Charged battery good still just bumps the motor and will not turn over. Oil has been drained.

open for suggestions on what to check before tearing the motor apart. possible some residual water in exhaust, have not disconnected to check.
 

·
Registered
Joined
·
5,651 Posts
Will it turn over with the plug removed?
If not, you probably have bent the connecting rod.
 
  • Like
Reactions: Vincent

·
Registered
04 Grizzly 660, XR650l carb swap, ROX risers
Joined
·
21 Posts
Will it turn over with the plug removed?
If not, you probably have bent the connecting rod.
+1 for possible bent rod

have you double checked yourself ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Well not sure yet still in the process of pulling the motor. It will manually role over just has one spot it gets hung up on. I will keep you posted.
 

·
Registered
04 Grizzly 660, XR650l carb swap, ROX risers
Joined
·
21 Posts
Well not sure yet still in the process of pulling the motor. It will manually role over just has one spot it gets hung up on. I will keep you posted.
yeah sounds like it got hydro locked and bent the rod, let us know what you find.
 

·
Premium Member
Joined
·
11,694 Posts
Or the timing got broke and a valve open to stop the engine.
 
1 - 6 of 6 Posts
Top