Yamaha Grizzly ATV Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
OK so ever since I rebuilt this 660 I have had a top end throttle problem. Sounds just like if you have a governor on in reverse. But this isn’t the case. So let me tell you what I do know so you won’t throw things at me that I’ve already done. First off I cleaned the carburetor. No restrictions in any office, plus the carburetor was relatively clean anyway. Second, timing is perfect without a doubt. Third, valves have been checked over and over again and they are perfect! There is a new stater, and a new CDI. I originally replaced the state are thinking maybe I had a weak spark at top end but no difference and then I thought maybe the CDI was acting up but no change with the new one. The only thing I have not physically changed is the coil. I have a video of me revving the engine but I cannot download it here. So if anybody is interested in the video send me your email and I’ll send it to you or a phone number. My phone number is 541-292-7688 my name is Tim ,I’ve been on here a long time but this one’s got me stumped! So I need somebody’s help.
 

·
Premium Member
Joined
·
8,347 Posts
"Top end throttle sounds governed" at what MPH is this happening?
Some 660's had a CDI issue that would randomly throw on the rev limiter. Usually limiting speed to 20-25 mph.
First thing to try is a new spark plug even if you had installed a new one.
You should ohm out that coil.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
"Top end throttle sounds governed" at what MPH is this happening?
Some 660's had a CDI issue that would randomly throw on the rev limiter. Usually limiting speed to 20-25 mph.
First thing to try is a new spark plug even if you had installed a new one.
You should ohm out that coil.
This happens stationary or moving. Coil is fine, CDI I just changed thinking maybe it was just that , same thing. If you have an email , I’ll send a quick vid I took .
 

·
Grizzled
2014 Yamaha Grizzly 700 EPS
Joined
·
3,841 Posts
Just post your video on somewhere like youtube or vimeo and then provide your link in another post in this thread. More people will be able to see it and provide feedback as well, there is a good amount of active 660 owners on this forum.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
My thoughts on my problem: possibly float adjustment (fuel shortage at top end ?
Or; slide diaphragm has a pin hole ? Fluctuates at open throttle?
 

·
Premium Member
Joined
·
8,347 Posts
My thoughts on my problem: possibly float adjustment (fuel shortage at top end ?
Or; slide diaphragm has a pin hole ? Fluctuates at open throttle?
All good possibilities.
But sure does sound like rev-limiter bounce.
Some members have had rev-limiter issues related to bad connections to the diff lock. Dirty connection, bent pins, frayed wires grounding out. I'm not sure, only guessing if the 4wd drive fuse was pulled would that eliminate the the 4wd rev-limiter? Consider giving it a try...it's free!
 

·
Premium Member
2020 Yamaha Kodiak 700 EPS SE
Joined
·
36 Posts
I would replace the coil. Best place to start..

Disclaimer.. I'm a FNG around here..
 

·
Premium Member
2020 Yamaha Kodiak 700 EPS SE
Joined
·
36 Posts
My thoughts exactly!

Inspect the plug wire or just replace it as well..
 

·
Premium Member
Joined
·
8,347 Posts

·
Registered
Joined
·
2 Posts
OK so ever since I rebuilt this 660 I have had a top end throttle problem. Sounds just like if you have a governor on in reverse. But this isn’t the case. So let me tell you what I do know so you won’t throw things at me that I’ve already done. First off I cleaned the carburetor. No restrictions in any office, plus the carburetor was relatively clean anyway. Second, timing is perfect without a doubt. Third, valves have been checked over and over again and they are perfect! There is a new stater, and a new CDI. I originally replaced the state are thinking maybe I had a weak spark at top end but no difference and then I thought maybe the CDI was acting up but no change with the new one. The only thing I have not physically changed is the coil. I have a video of me revving the engine but I cannot download it here. So if anybody is interested in the video send me your email and I’ll send it to you or a phone number. My phone number is 541-292-7688 my name is Tim ,I’ve been on here a long time but this one’s got me stumped! So I need somebody’s help.
I had the same problem and it ended up being the starter relay cheap fix about 10 to 20 bucks on Amazon
 

·
Registered
Joined
·
2 Posts
Because it feeds power to the engine and ignition switch if it is weak it acts like a kill switch being flipped on off on and so on instead on constant power also check the plug for a bad wire contact a neutral safety switch can also cause it to run like that
 
1 - 20 of 25 Posts
Top