Yamaha Grizzly ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
Hello GC,
So i did 1 day mud ridding in which i havent used winch and other day i was cleaning the grizz. And i wanted to clean everything so i pulled winch cable all way and cleaned everything and when i was pulling it back i noticed that it started doing clicking something noise and not pulling but just press button few times and it pulls again.
mine is same as this
 

·
Registered
Joined
·
275 Posts
You have any warranty time left? It sounds like something is not engaging properly, like when a car starter armature doesn't work properly and spins free.

I'd call the company.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #5
No waranty LOL its 2007grizz :D and no i use winch only when bike is running
 

·
Premium Member
Joined
·
789 Posts
Hello GC,
So i did 1 day mud ridding in which i havent used winch and other day i was cleaning the grizz. And i wanted to clean everything so i pulled winch cable all way and cleaned everything and when i was pulling it back i noticed that it started doing clicking something noise and not pulling but just press button few times and it pulls again. https://youtu.be/k1vRRBkdbEY mine is same as this
I got a FREE WARN winch with my 2007 Grizz 700 ,, and it lasted about 2 years ,, started doing what you are describing..
after carrying it around as dead weight for 6 years ,, broke down and bought a new one.. heard in between that time that WARN had some defective winches that got recalled ,, but I was never informed... If that is a 2007 ,, I say you got 3 times the life I did.. consider yourself lucky ! lol
 

·
Registered
Joined
·
171 Posts
Discussion Starter #7
:D well it sometimes pulls so ill use it until its working :D
 

·
Registered
Joined
·
171 Posts
Discussion Starter #8
Well the winch is like new again! :D all į had to do was to remove right side cower and clean everything there was mud caked in so the winch werent fully engaging
 
1 - 8 of 8 Posts
Top